University of Missouri

Interface

Skip to search and archives

Archives for May 2017

PHPCodeSniffer + PHPCompatibility For Checking Codebase Before Migration

Published on by Paul Gilzow | Posts by This Author

As I mentioned yesterday, if you want to use PHPCodeSniffer+PHPCompatibility make sure you are using the 2.9 version of PHPCodeSniffer.  Failing to see the notice in the PHPCompatibility Requirements section about it being incompatible with PHPCS3.0 will lead to several hours of hair-pulling and cursing at your screen. The PHPCompatibility standard is currently not compatible […]

Read More

Leave a Comment

Testing Your Codebase for the PHP7 Migration

Published on by Paul Gilzow | Posts by This Author

We are preparing to upgrade the Departmental Web Hosting Environment to PHP 7.0 within the next month.  Knowing that there are at least a few backwards incompatible changes between PHP 5.X and 7.0, the thought of combing through tens of thousands of lines of code is enough to cause a panic attack.  Thankfully, it doesn’t […]

Read More

Leave a Comment